
CabWriter 4.0.6 Release Notes – 2-10-2021 

New Functionality 

1. When debugging number 4 in Fixes below I noticed an issue that could cause the loss of 

production documentation. Previously, when a new CabWriter project was created the name of 

the .skp file was also used as the Project Name (see Project tab of CabWriter Settings). The user 

was free to change this Project Name, but often didn’t. This project name is used to create a 

folder in the same directory as the .skp file and this is where CabWriter’s production 

documentation is stored. User’s who use CutList Plus fx to create DXF files will find that CutList 

Plus fx stores those files in a folder with the same name as the .skp file name. That can be the 

same name as the folder containing the production documentation and CutList Plus fx creates 

this folder destructively. That is, if the folder existed before and contained production 

documentation it would be destroyed along with all its contents. 

 

So now, when you create a CabWriter project, CabWriter will still use the .skp file name for the 

Project Name, but it will append the word Project to it. For example, if your .skp file name is My 

Kitchen the Project Name will be My Kitchen Project. You are still free to change your Project 

Name to any legal name, but if you use CutList Plus fx in your work flow be sure it is not the 

SAME as the .skp file name. 

  



Fixes 

1. Fixed an issue where when a scene associated with Purchased Part Report is empty or has no 

visible CabWriter parts on it, and one of the Purchased Parts Reports is checked, an error would 

appear that made no sense. In the example shown below the Purchased Parts scene is empty or 

has no visible parts in it. The Doors report is checked. In the past an error message would 

appear, but didn’t help the user understand the problem. Below the Production Documentation 

dialog image is the new error message. 

 

 
 



 
 

2. Fixed a problem that would occur if a Purchased Part Report was requested when the door and 

drawer fronts were trimmed solid doors and drawer fronts. Some background is needed to 

understand this issue. 

 

Trimmed solid doors were a feature added to permit the ability to cut solid doors on a CNC 

machine with the door corrected in size to allow for the trim or banding. It was in lieu of cutting 

solid doors on a panel or table saw where the user could take advantage of over and under 

sizing. Over and under sizing parameters are ignored when creating DXF files for the CNC, hence 

the trimmed solid door. 

 

Trimmed solid doors and drawer fronts If they are included and not hidden an should never be 

included in a scene that is to be associated with Purchased Part Report (like the example in # 1 

above). If they are included in such a scene, along with normal solid or face frame doors and 

drawer fronts, they should be hidden. If they are included and not hidden, an error message 

such as below will appear. 

 

 
 

3. Fixed an issue where even if DXF by Material Name & Thickness weren’t checked as in the image 

below, DXF files were produced and the Sheet Optimization Settings dialog box opened. 

 



 
 

4. When using CutList Plus fx with DXF in the Select Milled Parts Reports section of the Production 

Documentation dialog box (see image above) to produce a .cwx file the contents of the File 

column was missing. This column is used to tell CutList Plus fx where to find the individual 

component DXF files produced by CabWriter. This resulted in CutList Plus fx producing DXF files 

with no internal geometry (holes, rabbets, dadoes etc.). 

 

  



CabWriter 4.0.5 Release Notes – 1-12-2021 

New Functionality 

  



Fixes 

1. Fixed an issue with face frame base cabinets that used a bottom rail, and where the bottom was 

inset. If the inset was such that the bottom protruded above the top of the bottom rail the 

drawer box was not correctly placed. Typically, it was placed higher in the drawer opening by 

the distance of the bottom inset. 
2. Fixed an issue where a warning would appear in the Ruby Console when creating reports. This 

was due to Ruby changes to the CSV Library in the Ruby interpreter used in SketchUp 2021. 
3. Fixed a problem where you might get the following error message: 

 

 
 

when you should have gotten this. 

 

 
 

The problem was that when CabWriter checks to see if an instance will fit on a sheet good, it did 

not take into account the Edge Margin parameter. 



4. Fixed an issue where some attributes were lost when multiple instances were selected and the 

Extended Entity Info dialog box was open to the Attributes tab. 

5. Fixed an issue with the placement of top/stretcher and bottom construction holes in the sides. 

The distance from the top or bottom of the sides of these holes was specified by ½ the thickness 

of the sides. The correct placement was ½ the thickness of the top/stretcher or bottom. This 

became an issue when the side thickness was different than the top/stretcher or bottom 

thickness. 

  



CabWriter 4.0.4 Release Notes – 12-2-2020 

New Functionality 

1. Changed the Extended Entity Info function of the Initialize Attributes button on the Setup tab. In 

the past it would only initialize attribute, but not the Comp #, because the Comp # is not 

technically and attribute. It now returns the Comp # to a blank entry. 

  



Fixes 

1. Fixed an issue with the optimization plots, both cut list and DXF, to all a 60” x 120” sheet to be 

displayed without protruding into the options and results area. 
2. Fixed a problem where if either W{-1/2”} or W(10”) were selected on the Extended Entity Info 

Setup tab, then any re-sized part would not be plotted on the Optimized Cut List Diagrams sheet 

diagrams. 
3. Fixed a problem where section views sent to LayOut would appear as isometric views in version 

21.0. This problem first cropped up in version 20.1 but the fix I made worked in all cases but 

21.0. 
4. Fixed a problem introduced with an earlier fix where when the Extended Entity Info dialog box is 

open and the user selects more than one component attributes could get lost. 

  



SketchUp 2021 Compatibility Changes 

1. Fixed an issue where Create Basic Scene Set raised an error when setting the visibility of a layer 

that didn’t exist for a scene.  



CabWriter 4.0.3 Release Notes – 10-4-2020 

New Functionality 

 

  



Fixes 

1. SketchUp made changes to the Ruby API in version 20.1.0 which I accounted for in CabWriter 

4.0.0. However, those changes were incompatible with older versions of SketchUp. I have 

corrected that incompatibility. If you have a version of SketchUp older than 20.1.0 and a version 

of CabWriter 4 older than 4.0.3 you may get an error message in the Ruby console when 

attempting a File > CabWriter to LayOut > Send Scenes to LayOut that begins with a line similar 

to the following: 

 

Error: #<NoMethodError: undefined method `camera_modified?' for 

#<Layout::SketchUpModel:0x0001b88f2e0c68>> 

 

2. Fixed a problem with the Extended Entity Info dialog box where checkbox changes on the 

Attributes tab were not sticking. 

  



CabWriter 4.0.2 Release Notes – 9-21-2020 

New Functionality 

1. Fixed the seven-day recurring check for an updated version of CabWriter. It was not informing 

the user of the availability of a newer version for download. A check for a newer version will 

now occur every seven days and if the latest version is newer than your installed version you will 

see the following message upon opening SketchUp. 

 

 

 

  



Fixes 

1. Fixed a problem with divided base and upper cabinet where the door may have a too small 

clearance above it at the top. 

2. Fixed a problem that resulted from changes in SketchUp which had to do with the handling of 

Fixnum and cloning. 

3. Fixed a problem with the Columns tab on the Extended Entity Info dialog box. Whenever the 

user changed one column line those that were entered on a previous session were lost. 

  



CabWriter 4.0.1 Release Notes – 8-25-2020 

New Functionality 

1. Users may have noticed that when using the File > CabWriter to LayOut > Send Scenes to LayOut 

the pages in LayOut do not look like their equivalent scene in SketchUp. SketchUp made a 

number of functionality changes in version 2020.1 that weren't there in 2020. Generally, 

functionality changes are made in major versions and not point versions, which are usually 

reserved for fixes. So, this may be a sign of things to come. Interestingly, the changes they made 

were to ignore the camera settings, layer (tag) visible check boxes and style settings used in the 

SketchUp model when the scenes are sent to LayOut. (Actually, they ignored the fog and 

shadow settings too, but we don't use them.) Seems dumb to me. I would think that using the 

SketchUp model settings would be the default. But what do I know? Anyway, they provided 

three new methods that restore the three SketchUp settings to what they were in the model 

and I have implemented them in this release. 

2. Created a new CabWriter component prefix for banding and/or trim. If your model has solid 

doors or drawer fronts, and you have chosen Enable CNC Cutting in the General Section of the 

Project tab, you will have banding/trim around those components. Their components names will 

be something like the following: 

 

C1LTR8 Drawer Rail Trim 

C1LTR8 Drawer Stile Trim 

 

The TR stands for Trim (or Banding). This prefix type was added and needed to fix a problem of 

CabWriter confusing solid door and drawer fronts with frame and panel drawer fronts, and also 

to keep these trim/banding parts from showing up on the Stiles and Rails reports and creating 

labels for those parts. 

 

3. Not sure if this is a new feature or a fix. I removed the prefixes P#: and CN: from the Component 

# and Description when creating labels. Through experimenting with my own cabinet builds and 

Greg’s opinion, these two lines on a label should always appear 1st (in bold black) and 2nd 

(italicized). The prefixes slows the cabinetmaker down when taking boards off the CNC machine 

because they make recognizing the Part Number and Description more difficult, hence making 

the selection of the correct label slower. Leaving them off speeds this process up significantly. 

Compare the before (left) and after (right) below. 

 

    
 



In addition I changed the Sheet Number prefix from S#: to Sheet:. 

  



Fixes 

1. Fixed a problem where CabWriter HOME on a Mac could result in the following error message 

with the settings shown. 

 

 

 

2. Fixed a problem where solid door trim/banding were being assigned the wrong CutList Bridge 

attributes. 

 

3. Fixed a problem when drawing drawer boxes using Draw > CabWriter > Create Drawer Box Parts 

and specifying a 0” dimension for either Slider Width or Slider Thickness or both. SketchUp 



raises an error. 

 

4. Fixed a problem with fixed shelf and stretcher holes in divided base and upper cabinets. Their 

diameter referenced system hole diameter, not construction hole diameter as they should. 

 

5. Fixed a problem with divided base and upper cabinets when the Back Attachment Method was 

chosen as either Inset Full or Inset Sides & Bottom. Either of these selections would result in 

mis-placement of fixed shelf back construction holes. 

 

6. Changed the Edge Margin default in the Planted Back Construction Holes section of CNC Boring 

tab from 1 ½” to 2 ¼” to prevent 7 x 50 mm Comfirmat screws drilled in the back from hitting 

Confirmit screws drilled into the sides and securing tops/bottoms/stretchers. If longer screw are 

used this parameter needs to be increased. 

 

7. When printing optimization reports and selecting both Cut List and Diagrams the first diagram 

page had the same page number as the last cut list page; i.e. it wasn’t incremented. 

 

8. When drawing a divided base or upper cabinet with drawers and doors, and no divider selected 

for the first compartment, the door and drawer fronts were not placed correctly. 


